Rex Route - Issues with Rex route Ad. – Incident details
Get updates
Email
Slack
Microsoft Teams
Google Chat
Webhook
RSS
Atom
API
Get updates
Dark mode
All systems operational
Issues with Rex route Ad.
Resolved
Degraded performance
Started 3 months ago
June 19, 2026
Lasted 6 minutes
June 19, 2026
5:56
6:02 PM
UTC
Affected
https://ad.rexroute.com
Degraded performance from 5:56 PM to 6:02 PM
Updates
Resolved
June 19, 2026 at 6:02 PM
UTC
Resolved
June 19, 2026 at 6:02 PM
UTC
This incident has been resolved.
Identified
June 19, 2026 at 6:01 PM
UTC
Identified
June 19, 2026 at 6:01 PM
UTC
We are continuing to work on a fix for this incident.
Investigating
June 19, 2026 at 5:56 PM
UTC
Investigating
June 19, 2026 at 5:56 PM
UTC
We are currently investigating this incident.
UTC
UTC
UTC
UTC
UTC
UTC
UTC